add harvested dev-util/cdecl to save from deprecation
[portage-squeep] / net-p2p / dogecoind / dogecoind-1.8.0.ebuild
index 743c0fbc29307e372490711bd9a1a6fde2f400e6..405c4fde0079ce269d4cbf6cbdef8e4fc5b65e20 100644 (file)
@@ -1,4 +1,6 @@
+# Copyright 1999-2014 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
+# $Header: $
 
 EAPI="5"
 
@@ -28,7 +30,9 @@ RDEPEND="
        upnp? (
                net-libs/miniupnpc
        )
-       sys-libs/db:$(db_ver_to_slot "${DB_VER}")[cxx]
+       wallet? (
+               sys-libs/db:$(db_ver_to_slot "${DB_VER}")[cxx]
+       )
 "
 DEPEND="${RDEPEND}
        >=app-shells/bash-4.1
@@ -44,20 +48,11 @@ pkg_setup() {
 }
 
 src_prepare() {
-       # bitcoin for some reason doesn't use embedded leveldb
-       # but we will, because version/bug pinning is a good thing
-#      rm -r src/leveldb
-#      sed -e 's/^\(LIBLEVELDB=\).*$/\1-lleveldb/' \
-#              -e 's/^\(LIBMEMENV=\).*$/\1-lmemenv/' \
-#              -e 's/^\(AM_CONDITIONAL(\[EMBEDDED_LEVELDB\],\[\).*\(\])\)$/\1false\2/' \
-#              -i configure.ac
-
        eautoreconf
 }
 
 src_configure() {
        econf \
-               --disable-silent-rules \
                $(use_enable wallet) \
                $(use_enable test tests) \
                --disable-hardening \