add harvested dev-util/cdecl to save from deprecation
authorJustin Wind <justin.wind+git@gmail.com>
Sun, 19 Jun 2016 18:24:20 +0000 (11:24 -0700)
committerJustin Wind <justin.wind+git@gmail.com>
Sun, 19 Jun 2016 18:24:20 +0000 (11:24 -0700)
dev-util/cdecl/Manifest [new file with mode: 0644]
dev-util/cdecl/cdecl-2.5-r2.ebuild [new file with mode: 0644]
dev-util/cdecl/files/cdecl-2.5-implicit-pointer.patch [new file with mode: 0644]
dev-util/cdecl/files/cdecl-2.5.patch [new file with mode: 0644]
dev-util/cdecl/metadata.xml [new file with mode: 0644]

diff --git a/dev-util/cdecl/Manifest b/dev-util/cdecl/Manifest
new file mode 100644 (file)
index 0000000..e1a30ec
--- /dev/null
@@ -0,0 +1,5 @@
+AUX cdecl-2.5-implicit-pointer.patch 502 SHA256 0dadb6e9869547ebe654fec16fc61b14b4e2006c8ff9b181aa9bb7eac5645e8b SHA512 25e499642f8ebfe3b7d39343e48beaaa99ef501dbb1304f4fd046a1a80013ef8faf5e7c153a927066738e9a3d287fd3af88301f3d0b56b04c6a9b4b02c11c8a5 WHIRLPOOL 58f497bdc820ad969546de197ade06f9d96c9d7cc78c3b177f513114f98e3914068591e685d586d55377a5965ac799eacdd90aea6aba7e4b5dfa59fd23d07675
+AUX cdecl-2.5.patch 1891 SHA256 29be443674ab4b330cf0ed152263db0539df02ad5cd30a7010cb7a9bcfdd1ad6 SHA512 f0fa8d70d5e02693ac88952e8957b30e9a7c514ba8ce53eec8bf17d234871ea5f6192aa8289e38e1ad13665fb3911a9512c57428022bfcaaa5f76a38b3027221 WHIRLPOOL e9fbfb171965822968a65a659932151a00a7273ba02f5e6cbbdb3cbeb0e1100f636706f99e261d88d1b1abf0eb4342b6466343059422477da6310fdb96acfbb9
+DIST cdecl-2.5.tar.gz 21435 SHA256 b74caef08407a2195d6f1facf103e5af29253f67d599486164241b14ee42a936 SHA512 15495f5a794d11f964297c1f39f2f62f89778cd2e791b93f7e6cf16f321a71205a1f9366960f62b030022699e8abacaa5b402a304fb2eab8c00c83b9a4d0b419 WHIRLPOOL b9a3cc84689e2c60db6e733de0a3d428be4e5537908c132f69f2d27618ed8f4064faeb2faae7d20b9811088c7adf33838185eee2102710e4a9906638391883f9
+EBUILD cdecl-2.5-r2.ebuild 1008 SHA256 404cee55f10d5fd4d2c4bead1dd30f411e5714cc267b87006b090b712b8d5105 SHA512 4a7b75d5df6c325c6e9597cee3e1dbb6ddbea49f581ab040411b18709b5a0800306d16a84af7186cfdab6abb412abac6db02e682a536e15dd077853324cf9d70 WHIRLPOOL 811fff09e12e09bc676fe795db23885f36fbe12727d8ba2cb6ec679a051e1f84078ed18978706e8acc4d757310db72a49218c30276c186ea416fd560b18ef1ff
+MISC metadata.xml 166 SHA256 2caff447f5bd2701d8456ada5cc633c41ef4373fa4bfeabeb73599d40bcc941b SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84 WHIRLPOOL 1ff70497eca6531f0e0614c72a19f4b8e5ff486a58d369f4f0b36308d1d6b01168f9da887740e3b9f536236be251d3fe05f904d27a9233a7cf613416ba882968
diff --git a/dev-util/cdecl/cdecl-2.5-r2.ebuild b/dev-util/cdecl/cdecl-2.5-r2.ebuild
new file mode 100644 (file)
index 0000000..ebeaff4
--- /dev/null
@@ -0,0 +1,49 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Turn English phrases to C or C++ declarations"
+SRC_URI="ftp://ftp.netsw.org/softeng/lang/c/tools/cdecl/${P}.tar.gz"
+HOMEPAGE="http://www.boutell.com/lsm/lsmbyid.cgi/002103"
+
+KEYWORDS="amd64 ~mips ppc x86"
+LICENSE="public-domain"
+SLOT="0"
+
+RDEPEND="readline? (
+                       sys-libs/ncurses
+                       sys-libs/readline
+                       )"
+
+DEPEND="${RDEPEND}
+               || (
+                       dev-util/yacc
+                       sys-devel/bison
+                       )
+               !<dev-util/cutils-1.6-r2"
+
+IUSE="readline"
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+       epatch "${FILESDIR}/${P}.patch"
+       epatch "${FILESDIR}/${P}-implicit-pointer.patch"
+}
+
+src_compile() {
+       if use readline; then
+               CFLAGS="${CFLAGS} -DUSE_READLINE"
+               LIBS="${LIBS} -lreadline -lncurses"
+       fi
+       emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" LIBS="${LIBS}" || die
+}
+
+src_install() {
+       dobin cdecl
+       dohard /usr/bin/cdecl /usr/bin/c++decl
+       dodoc README
+       doman *.1
+}
diff --git a/dev-util/cdecl/files/cdecl-2.5-implicit-pointer.patch b/dev-util/cdecl/files/cdecl-2.5-implicit-pointer.patch
new file mode 100644 (file)
index 0000000..ee4949b
--- /dev/null
@@ -0,0 +1,12 @@
+Index: cdecl-2.5/cdecl.c
+===================================================================
+--- cdecl-2.5.orig/cdecl.c
++++ cdecl-2.5/cdecl.c
+@@ -204,6 +204,7 @@ int DebugFlag = 0;         /* -d, output debugg
+ #define ANSI  4       /* combo not allowed anymore in ANSI compiler */
+ #define A     ANSI
++extern char **completion_matches PARAMS((char *, rl_compentry_func_t *));
+ /* This is an lower left triangular array. If we needed */
+ /* to save 9 bytes, the "long" row can be removed. */
+ char crosscheck[9][9] = {
\ No newline at end of file
diff --git a/dev-util/cdecl/files/cdecl-2.5.patch b/dev-util/cdecl/files/cdecl-2.5.patch
new file mode 100644 (file)
index 0000000..ed04d59
--- /dev/null
@@ -0,0 +1,71 @@
+--- cdecl.c
++++ cdecl.c.new
+@@ -67,6 +67,7 @@
+ # include <stddef.h>
+ # include <string.h>
+ # include <stdarg.h>
++# include <errno.h>
+ #else
+ # ifndef NOVARARGS
+ #  include <varargs.h>
+@@ -124,7 +125,6 @@
+ #if __STDC__
+   char *ds(char *), *cat(char *, ...), *visible(int);
+-  int getopt(int,char **,char *);
+   int main(int, char **);
+   int yywrap(void);
+   int dostdin(void);
+
+--- cdecl.c    2009-07-07 13:20:37.000000000 +0200
++++ cdecl.c.new        2009-07-07 13:25:00.000000000 +0200
+@@ -91,7 +91,7 @@
+ #ifdef USE_READLINE
+ # include <readline/readline.h>
+   /* prototypes for functions related to readline() */
+-  char * getline();
++  char * mygetline();
+   char ** attempt_completion(char *, int, int);
+   char * keyword_completion(char *, int);
+   char * command_completion(char *, int);
+@@ -375,7 +375,7 @@
+ static char *line_read = NULL;
+ /* Read a string, and return a pointer to it.  Returns NULL on EOF. */
+-char * getline ()
++char * mygetline ()
+ {
+   /* If the buffer has already been allocated, return the memory
+      to the free pool. */
+@@ -887,7 +887,7 @@
+       if (!quiet) (void) printf("Type `help' or `?' for help\n");
+       ret = 0;
+-      while ((line = getline())) {
++      while ((line = mygetline())) {
+           if (!strcmp(line, "quit") || !strcmp(line, "exit")) {
+               free(line);
+               return ret;
+--- Makefile.old       2010-08-26 22:06:28.000000000 +0200
++++ Makefile   2010-08-26 22:11:42.000000000 +0200
+@@ -15,9 +15,9 @@
+ #
+ # add -DUSE_READLINE  To compile in support for the GNU readline library.
+-CFLAGS= -s -O2 -DUSE_READLINE
++
+ CC= gcc
+-LIBS= -lreadline -ltermcap
++
+ ALLFILES= makefile cdgram.y cdlex.l cdecl.c cdecl.1 testset testset++
+ BINDIR= /usr/bin
+ MANDIR= /usr/man/man1
+@@ -29,7 +29,7 @@
+       ln c++decl cdecl
+ c++decl: cdgram.c cdlex.c cdecl.c
+-      $(CC) $(CFLAGS) -o c++decl cdecl.c $(LIBS)
++      $(CC) $(CFLAGS) ${LDFLAGS} -o c++decl cdecl.c $(LIBS)
+       rm -f cdecl
+ cdlex.c: cdlex.l
diff --git a/dev-util/cdecl/metadata.xml b/dev-util/cdecl/metadata.xml
new file mode 100644 (file)
index 0000000..6f49eba
--- /dev/null
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<!-- maintainer-needed -->
+</pkgmetadata>