add www-apps/fcgi-auth-pam
[portage-squeep] / www-apps / fcgi-auth-pam / fcgi-auth-pam-9999.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 if [[ ${PV} = *9999* ]]; then
7 EGIT_REPO_URI="https://github.com/thylacine/${PN}.git"
8 LIVE_ECLASSES="git-r3"
9 LIVE_EBUILD=yes
10 fi
11
12 inherit flag-o-matic ${LIVE_ECLASSES}
13
14 if [[ -z ${LIVE_EBUILD} ]]; then
15 SRC_URI="https://github.com/thylacine/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
16 KEYWORDS="~amd64 ~x86"
17 fi
18
19 DESCRIPTION="A fastcgi responder which does Basic authentication vi PAM."
20 HOMEPAGE="https://github.com/thylacine/fcgi-auth-pam"
21
22 LICENSE="BSD"
23 SLOT="0"
24 IUSE="+thread"
25
26 DEPEND="dev-libs/fcgi"
27 RDEPEND="${DEPEND}"
28
29 src_install() {
30 dosbin fcgi_auth_pam
31 }
32