new dev-util/cdecl
[portage-squeep] / net-mail / vacation / vacation-1.2.7.1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=0
5
6 inherit eutils toolchain-funcs
7
8 DESCRIPTION="automatic mail answering program"
9 HOMEPAGE="http://vacation.sourceforge.net/"
10 SRC_URI="mirror://sourceforge/vacation/${P}.tar.gz"
11 LICENSE="GPL-2"
12 KEYWORDS="alpha amd64 x86"
13 SLOT="0"
14 IUSE=""
15
16 RDEPEND="virtual/mta
17 sys-libs/gdbm"
18 DEPEND="${RDEPEND}
19 !mail-mta/sendmail"
20
21 src_unpack() {
22 unpack ${A}
23 cd "${S}"
24
25 sed -i -e "s:install -s -m:install -m:" Makefile
26 sed -i -e "s:-Xlinker:${LDFLAGS} -Xlinker:" Makefile
27 }
28
29 src_compile () {
30 emake CC=$(tc-getCC) ARCH=$(tc-arch-kernel) CFLAGS="${CFLAGS} -DMAIN" || die "emake failed."
31 }
32
33 src_install () {
34 dodir /usr/bin
35 dodir /usr/share/man/man1
36 emake BINDIR="${D}/usr/bin" MANDIR="${D}usr/share/man/man" install || die \
37 "make install failed"
38 }