add net-dns/rust-doh
[portage-squeep] / net-dns / rust-doh / rust-doh-0.1.7.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 CRATES="
7 base64-0.9.2
8 byteorder-1.2.3
9 futures-0.1.21
10 safemem-0.2.0
11 clap-2.31.2
12 bitflags-1.0.3
13 bitflags-0.9.1
14 textwrap-0.9.0
15 lipsum-0.5.0
16 rand-0.5.0
17 rand-0.4.2
18 rand-0.3.22
19 rand_core-0.2.0
20 serde-1.0.64
21 serde_derive-1.0.65
22 serde_test-1.0.65
23 proc-macro2-0.4.4
24 unicode-xid-0.1.0
25 quote-0.6.3
26 syn-0.14.1
27 bincode-1.0.0
28 hyphenation-0.6.1
29 fnv-1.0.6
30 hyphenation_commons-0.6.1
31 pocket-resources-0.3.2
32 unicode-normalization-0.1.7
33 unicode-segmentation-1.2.1
34 quickcheck-0.6.2
35 log-0.4.1
36 log-0.3.9
37 cfg-if-0.1.3
38 env_logger-0.5.10
39 humantime-1.1.1
40 quick-error-1.2.2
41 termcolor-0.3.6
42 regex-1.0.0
43 aho-corasick-0.6.4
44 memchr-2.0.1
45 libc-0.2.42
46 regex-syntax-0.6.0
47 ucd-util-0.1.1
48 thread_local-0.3.5
49 unreachable-1.0.0
50 void-1.0.2
51 utf8-ranges-1.0.0
52 unicode-width-0.1.5
53 ansi_term-0.11.0
54 atty-0.2.10
55 termion-1.5.1
56 redox_syscall-0.1.40
57 redox_termios-0.1.1
58 strsim-0.7.0
59 term_size-0.3.1
60 vec_map-0.8.1
61 yaml-rust-0.4.0
62 linked-hash-map-0.5.1
63 heapsize-0.4.2
64 lazy_static-1.0.1
65 spin-0.4.8
66 version-sync-0.5.0
67 itertools-0.7.8
68 either-1.5.0
69 pulldown-cmark-0.1.2
70 getopts-0.2.17
71 semver-parser-0.7.0
72 toml-0.4.6
73 url-1.7.0
74 idna-0.1.4
75 unicode-bidi-0.3.4
76 flame-0.2.2
77 thread-id-3.3.0
78 serde_json-1.0.19
79 dtoa-0.4.2
80 itoa-0.4.1
81 flamer-0.2.2
82 matches-0.1.6
83 percent-encoding-1.0.1
84 futures-0.2.1
85 futures-async-runtime-0.2.1
86 futures-channel-0.2.1
87 futures-core-0.2.1
88 futures-executor-0.2.1
89 num_cpus-1.8.0
90 futures-io-0.2.1
91 futures-sink-0.2.1
92 futures-stable-0.2.1
93 futures-util-0.2.1
94 futures-macro-async-0.2.1
95 futures-macro-await-0.2.1
96 hyper-0.11.27
97 relay-0.1.1
98 mime-0.3.7
99 unicase-2.1.0
100 version_check-0.1.3
101 language-tags-0.2.2
102 bytes-0.4.8
103 h2-0.1.9
104 indexmap-1.0.1
105 slab-0.4.0
106 slab-0.3.0
107 string-0.1.0
108 http-0.1.5
109 httparse-1.2.4
110 iovec-0.1.2
111 time-0.1.40
112 want-0.0.4
113 try-lock-0.1.0
114 futures-cpupool-0.1.8
115 net2-0.2.32
116 tokio-0.1.6
117 tokio-core-0.1.17
118 tokio-proto-0.1.1
119 tokio-service-0.1.0
120 scoped-tls-0.1.2
121 smallvec-0.6.1
122 smallvec-0.2.1
123 take-0.1.0
124 mio-0.6.14
125 fuchsia-zircon-0.3.3
126 fuchsia-zircon-sys-0.3.3
127 lazycell-0.6.0
128 miow-0.3.1
129 miow-0.2.1
130 socket2-0.3.6
131 tokio-io-0.1.6
132 tokio-fs-0.1.0
133 tokio-timer-0.1.2
134 tokio-timer-0.2.3
135 tokio-threadpool-0.1.3
136 crossbeam-deque-0.3.1
137 crossbeam-epoch-0.4.1
138 crossbeam-utils-0.4.0
139 crossbeam-utils-0.3.2
140 arrayvec-0.4.7
141 nodrop-0.1.12
142 nodrop-union-0.1.9
143 memoffset-0.2.1
144 scopeguard-0.3.3
145 tokio-tcp-0.1.0
146 futures2-0.1.0
147 tokio-udp-0.1.0
148 tokio-reactor-0.1.1
149 tokio-executor-0.1.2
150 clippy-0.0.206
151 clippy_lints-0.0.206
152 cargo_metadata-0.5.5
153 error-chain-0.11.0
154 backtrace-0.3.8
155 backtrace-sys-0.1.23
156 cc-1.0.7
157 rustc-demangle-0.1.8
158 if_chain-0.1.2
159 quine-mc_cluskey-0.2.4
160 quickcheck-0.6.2
161 regex-syntax-0.6.0
162 rustc_version-0.2.2
163 semver-0.9.0
164 kernel32-sys-0.2.2
165 winapi-0.2.8
166 winapi-0.3.4
167 winapi-i686-pc-windows-gnu-0.4.0
168 winapi-x86_64-pc-windows-gnu-0.4.0
169 winapi-build-0.1.1
170 ws2_32-sys-0.2.1
171 "
172
173 inherit cargo
174
175 DESCRIPTION="A DNS-over-HTTP server proxy"
176 HOMEPAGE="https://github.com/jedisct1/rust-doh"
177 SRC_URI="https://github.com/jedisct1/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
178 $(cargo_crate_uris ${CRATES})
179 "
180
181 SLOT="0"
182 LICENSE="GPL-3"
183 KEYWORDS="~amd64 ~x86"
184
185 RDEPEND="dev-libs/openssl:*"
186 DEPEND="${RDEPEND}
187 virtual/rust"
188
189 src_test() {
190 debug-print-function ${FUNCNAME} "$0"
191
192 export CARGO_HOME="${ECARGO_HOME}"
193
194 cargo test --release || die "Tests failed"
195 }
196
197 src_install() {
198 cargo_src_install || die "Installation failed"
199
200 # einstalldocs
201 # doman ${PN}.1
202 }