update forked-daapd
[portage-squeep] / media-sound / forked-daapd / forked-daapd-26.4.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 # TODO:
5 # Add --enable-spotify when it works
6
7 EAPI=5
8
9 inherit autotools eutils user
10
11 DESCRIPTION="A DAAP (iTunes) media server"
12 HOMEPAGE="https://github.com/ejurgensen/forked-daapd"
13 #SRC_URI="https://github.com/ejurgensen/forked-daapd/archive/${PV}.tar.xz -> ${P}.tar.xz"
14 SRC_URI="https://github.com/ejurgensen/forked-daapd/releases/download/${PV}/${P}.tar.xz"
15 LICENSE="GPL-2"
16 SLOT="0"
17 KEYWORDS="~amd64"
18 IUSE="alsa flac itunes lastfm mpd musepack"
19
20 # Note: mpd support appears to be standalone, e.g. --enable-mpd doesn't
21 # result in additional linkage.
22 RDEPEND="
23 dev-db/sqlite:3
24 dev-libs/antlr-c:0
25 dev-libs/confuse
26 dev-libs/libevent
27 dev-libs/libgcrypt:0
28 dev-libs/libunistring
29 dev-libs/mxml[threads]
30 net-dns/avahi[dbus]
31 virtual/ffmpeg
32 dev-libs/json-c
33
34 alsa? ( media-libs/alsa-lib )
35 flac? ( media-libs/flac )
36 itunes? ( app-pda/libplist )
37 lastfm? ( net-misc/curl )
38 musepack? ( media-libs/taglib )
39 "
40
41 DEPEND="
42 dev-java/antlr:3
43 ${RDEPEND}
44 "
45
46 pkg_setup() {
47 enewuser daapd
48 enewgroup daapd
49 }
50
51 src_prepare() {
52 # https://github.com/ejurgensen/forked-daapd/pull/185
53 #epatch "${FILESDIR}/antlr-3.5.patch"
54
55 eautoreconf
56 }
57
58 src_configure() {
59 ac_cv_prog_ANTLR=antlr3.5 \
60 econf \
61 $(use_enable alsa) \
62 $(use_enable flac) \
63 $(use_enable musepack) \
64 $(use_enable itunes) \
65 $(use_enable lastfm) \
66 $(use_enable mpd)
67 }
68
69 src_install() {
70 emake DESTDIR="${D}" install
71
72 newinitd "${FILESDIR}/daapd.initd" daapd
73 newconfd "${FILESDIR}/daapd.confd" daapd
74
75 # dodir by itself fails in the likely case of /srv/music having a
76 # volume mounted already.
77 test -d /srv/music || dodir /srv/music
78
79 fowners -R daapd:daapd /var/lib/cache/forked-daapd
80 }