updated fbmuck ebuilds
[portage-squeep] / games-server / fbmuck / fbmuck-6.11.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils fixheadtails
6
7 IUSE="ssl ipv6 diskbase debug pcre"
8
9 DESCRIPTION="A database-backed multi-user chat server."
10 SRC_URI="mirror://sourceforge/fbmuck/${P}.tar.gz"
11 HOMEPAGE="http://www.belfry.com/fuzzball/"
12
13 SLOT="0"
14 LICENSE="GPL-2"
15 KEYWORDS="x86 amd64"
16
17 DEPEND=">=sys-apps/sed-4
18 ssl? ( dev-libs/openssl )"
19
20 RDEPEND="ssl? ( dev-libs/openssl )
21 pcre? ( dev-libs/libpcre )"
22
23 RESTRICT="strip"
24
25 src_unpack() {
26 unpack ${A}
27 ht_fix_all
28 # epatch ${FILESDIR}/${P}-gentoo.patch
29 }
30
31 src_compile() {
32 use diskbase && sed -i -e 's:#undef DISKBASE:#define DISKBASE:' include/config.h
33 econf \
34 `use_with ssl ssl=/usr` \
35 `use_with pcre pcre=/usr` \
36 `use_enable ipv6` \
37 `use_enable debug` \
38 || die "Could not configure"
39 emake || die "Could not make"
40 }
41
42 src_install() {
43 dodir /usr/bin
44 keepdir /usr/share/fbmuck
45
46 make DESTDIR="${D}" install || die "Could not install"
47
48 exeinto /usr/bin
49 doexe "${FILESDIR}"/fbmuckctl
50
51 exeinto /etc/init.d
52 doexe "${FILESDIR}"/fbmuck
53
54 insinto /etc
55 doins "${FILESDIR}"/fbmucks
56
57 dodoc CHANGESfb6 INSTALLATION README
58 }