new dev-util/cdecl
[portage-squeep] / dev-util / cdecl / cdecl-10.2.ebuild
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=8
5
6 #inherit eutils toolchain-funcs
7
8 DESCRIPTION="Compose and decipher C (or C++) declarations or casts, aka 'gibberish.'"
9 SRC_URI="https://github.com/paul-j-lucas/cdecl/releases/download/${P}/${P}.tar.gz"
10 HOMEPAGE="https://github.com/paul-j-lucas/cdecl"
11
12 KEYWORDS="amd64 x86"
13 LICENSE="public-domain"
14 SLOT="0"
15
16 RDEPEND="readline? (
17 sys-libs/ncurses
18 sys-libs/readline
19 )"
20
21 DEPEND="${RDEPEND}
22 || (
23 dev-util/yacc
24 sys-devel/bison
25 )
26 !<dev-util/cutils-1.6-r2"
27
28 IUSE="readline"
29
30 src_install() {
31 emake DESTDIR="${D}" install
32 }