add app-admin/apache-toos-2.4.18
authorJustin Wind <justin.wind+git@gmail.com>
Mon, 7 Oct 2019 16:34:48 +0000 (09:34 -0700)
committerJustin Wind <justin.wind+git@gmail.com>
Mon, 7 Oct 2019 16:34:48 +0000 (09:34 -0700)
app-admin/apache-tools/Manifest [new file with mode: 0644]
app-admin/apache-tools/apache-tools-2.4.18.ebuild [new file with mode: 0644]
app-admin/apache-tools/files/apache-tools-2.2.20-Makefile.patch [new file with mode: 0644]
app-admin/apache-tools/files/apache-tools-2.4.7-Makefile.patch [new file with mode: 0644]
app-admin/apache-tools/metadata.xml [new file with mode: 0644]

diff --git a/app-admin/apache-tools/Manifest b/app-admin/apache-tools/Manifest
new file mode 100644 (file)
index 0000000..4d65335
--- /dev/null
@@ -0,0 +1,5 @@
+AUX apache-tools-2.2.20-Makefile.patch 1573 BLAKE2B 56de28f38934b73740d68f6429f3361bfd37f079f1f6de4e169741e7c97bceed86330744c1b69045f8ffee0baf927e35e0eca10036d2da461f14e45cd218e5cd SHA512 85120f1b57cd14baf3482dc21d4175447e135700a1f8e6455970c14e576cb0c510815681a9906de4c7eb68743de7e41bbb2d86e83dcb62cd57eb0c9f638f6892
+AUX apache-tools-2.4.7-Makefile.patch 1695 BLAKE2B 8fac145613ac9f587e49bc6932c5712b7d7cad0d91422e11701edd24152e1d33907cbf31e3bef709555253759cea72199d4537df5d20d3ce9ca5dc898ba26779 SHA512 f597ce5503e590ed5b2621c04dcf0a571a73b70f144df7fe4e5fb7329a4f1558a5eb16913fe3d7c58ac1030f46cd2b1882e08d0f62106fbf8d40a8677c6b9448
+DIST httpd-2.4.18.tar.bz2 5181291 BLAKE2B 098c03e2a25feed1a891a9cd9c74f5ecdd7828e18981d845e45b715b5a60d67390cc91c2f77bfa18c64d7f077fa6195576cc682e9f2bef482adadaa3591b355b SHA512 8e342cc447313c07275869381c2d6f2314a96547f0c86ee1c617975d0f7ad8efb47113ab5995c733108ae4dec31ad79847e397ecea859b60414ffe1680617a31
+EBUILD apache-tools-2.4.18.ebuild 2585 BLAKE2B 5b6c2e8d094651ac43b366a94649969eaaa3270f54e5831427f0ff375b611b64469fd0cac2f70d8c018463466467c0d0217b075bad328c5858d30c5998fe6ed6 SHA512 02b7cb7935952cf53449dd32193c54fcf055f1f466cd2e58913e38caeac6c88b472afe29cf3fecc5435ccedb9d551b8ca5f4c413d6e49db094ff232d730690fb
+MISC metadata.xml 580 BLAKE2B 013a1f5cecbfa1086e720d341855be076e98b313f03ad99147bc692a5988fc6e0006545104cfe245798f88ab617c6e2c84928d0a73d127715dcb8ba352e8aa94 SHA512 611ed7b76b150a829902110a843a5a97622d2ec645850b6988c578496d716019e511830767a0c3dc300c69f02b5b933c806ea5598f6938b5d6b9d14b58985122
diff --git a/app-admin/apache-tools/apache-tools-2.4.18.ebuild b/app-admin/apache-tools/apache-tools-2.4.18.ebuild
new file mode 100644 (file)
index 0000000..3632490
--- /dev/null
@@ -0,0 +1,97 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit flag-o-matic eutils multilib toolchain-funcs
+
+DESCRIPTION="Useful Apache tools - htdigest, htpasswd, ab, htdbm"
+HOMEPAGE="http://httpd.apache.org/"
+SRC_URI="mirror://apache/httpd/httpd-${PV}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc64-solaris ~x64-solaris"
+IUSE="libressl ssl"
+RESTRICT="test"
+
+RDEPEND=">=dev-libs/apr-1.5.0:1
+       dev-libs/apr-util:1
+       dev-libs/expat
+       dev-libs/libpcre
+       kernel_linux? ( sys-apps/util-linux )
+       ssl? (
+               !libressl? ( dev-libs/openssl:0= )
+               libressl? ( dev-libs/libressl:= )
+       )"
+
+DEPEND="${RDEPEND}
+       sys-devel/libtool"
+
+S="${WORKDIR}/httpd-${PV}"
+
+src_prepare() {
+       epatch "${FILESDIR}"/${PN}-2.4.7-Makefile.patch #459446
+
+       # This package really should upgrade to using pcre's .pc file.
+       cat <<-\EOF >"${T}"/pcre-config
+       #!/bin/sh
+       [ "${flag}" = "--version" ] && set -- --modversion
+       exec ${PKG_CONFIG} libpcre "$@"
+       EOF
+       chmod a+x "${T}"/pcre-config
+}
+
+src_configure() {
+       # Brain dead check.
+       tc-is-cross-compiler && export ap_cv_void_ptr_lt_long="no"
+
+       tc-export PKG_CONFIG
+
+       # Instead of filtering --as-needed (bug #128505), append --no-as-needed
+       append-ldflags $(no-as-needed)
+
+       # econf overwrites the stuff from config.layout.
+       ac_cv_path_PKGCONFIG=${PKG_CONFIG} \
+       econf \
+               --libexecdir="${EPREFIX}"/usr/$(get_libdir)/apache2/modules \
+               --sbindir="${EPREFIX}"/usr/sbin \
+               --with-perl="${EPREFIX}"/usr/bin/perl \
+               --with-expat="${EPREFIX}"/usr \
+               --with-z="${EPREFIX}"/usr \
+               --with-apr="${SYSROOT}${EPREFIX}"/usr \
+               --with-apr-util="${SYSROOT}${EPREFIX}"/usr \
+               --with-pcre="${T}"/pcre-config \
+               $(use_enable ssl) \
+               $(usex ssl '--with-ssl="${EPREFIX}"/usr' '')
+       sed -i \
+               -e '/^LTFLAGS/s:--silent::' \
+               build/rules.mk build/config_vars.mk || die
+}
+
+src_compile() {
+       emake -C support
+}
+
+src_install() {
+       emake -C support DESTDIR="${D}" install
+       dodoc CHANGES
+       doman docs/man/{dbmmanage,htdigest,htpasswd,htdbm,ab,logresolve}.1 \
+               docs/man/{htcacheclean,rotatelogs}.8
+
+       # Providing compatiblity symlinks for #177697 (which we'll stop to install
+       # at some point).
+       pushd "${ED}"/usr/sbin >/dev/null || die
+       local i
+       for i in *; do
+               dosym ${i} /usr/sbin/${i}2
+       done
+       popd >/dev/null || die
+
+       # Provide a symlink for ab-ssl
+       if use ssl; then
+               dosym ab /usr/bin/ab-ssl
+               dosym ab /usr/bin/ab2-ssl
+       fi
+}
+
diff --git a/app-admin/apache-tools/files/apache-tools-2.2.20-Makefile.patch b/app-admin/apache-tools/files/apache-tools-2.2.20-Makefile.patch
new file mode 100644 (file)
index 0000000..7bc3952
--- /dev/null
@@ -0,0 +1,41 @@
+=== modified file 'support/Makefile.in'
+--- a/support/Makefile.in
++++ b/support/Makefile.in
+@@ -1,9 +1,10 @@
+ DISTCLEAN_TARGETS = apxs apachectl dbmmanage log_server_status \
+-      logresolve.pl phf_abuse_log.cgi split-logfile envvars-std
++      logresolve.pl phf_abuse_log.cgi split-logfile
+ CLEAN_TARGETS = suexec
+-PROGRAMS = htpasswd htdigest rotatelogs logresolve ab htdbm htcacheclean httxt2dbm $(NONPORTABLE_SUPPORT)
++PROGRAMS = htpasswd htdigest rotatelogs logresolve ab htdbm htcacheclean httxt2dbm \
++      $(NONPORTABLE_SUPPORT) log_server_status split-logfile dbmmanage
+ TARGETS  = $(PROGRAMS)
+ PROGRAM_LDADD        = $(UTIL_LDFLAGS) $(PROGRAM_DEPENDENCIES) $(EXTRA_LIBS) $(AP_LIBS)
+@@ -12,22 +13,13 @@
+ include $(top_builddir)/build/rules.mk
+ install:
+-      @test -d $(DESTDIR)$(bindir) || $(MKINSTALLDIRS) $(DESTDIR)$(bindir)
+       @test -d $(DESTDIR)$(sbindir) || $(MKINSTALLDIRS) $(DESTDIR)$(sbindir)
+-      @test -d $(DESTDIR)$(libexecdir) || $(MKINSTALLDIRS) $(DESTDIR)$(libexecdir)
+-      @cp -p $(top_builddir)/server/httpd.exp $(DESTDIR)$(libexecdir)
+-      @for i in apxs apachectl dbmmanage; do \
++      @for i in $(PROGRAMS) ; do \
+           if test -f "$(builddir)/$$i"; then \
+               cp -p $$i $(DESTDIR)$(sbindir); \
+               chmod 755 $(DESTDIR)$(sbindir)/$$i; \
+           fi ; \
+       done
+-      @if test -f "$(builddir)/envvars-std"; then \
+-          cp -p envvars-std $(DESTDIR)$(sbindir); \
+-          if test ! -f $(DESTDIR)$(sbindir)/envvars; then \
+-              cp -p envvars-std $(DESTDIR)$(sbindir)/envvars ; \
+-          fi ; \
+-      fi
+ htpasswd_OBJECTS = htpasswd.lo
+ htpasswd: $(htpasswd_OBJECTS)
+
diff --git a/app-admin/apache-tools/files/apache-tools-2.4.7-Makefile.patch b/app-admin/apache-tools/files/apache-tools-2.4.7-Makefile.patch
new file mode 100644 (file)
index 0000000..b7d3c27
--- /dev/null
@@ -0,0 +1,47 @@
+https://bugs.gentoo.org/459446
+
+https://raw.github.com/archlinuxcn/repo/master/apache-tools/apache-tools-Makefile.patch
+
+--- a/support/Makefile.in
++++ b/support/Makefile.in
+@@ -1,9 +1,9 @@
+ DISTCLEAN_TARGETS = apxs apachectl dbmmanage log_server_status \
+-      logresolve.pl phf_abuse_log.cgi split-logfile envvars-std
++      logresolve.pl phf_abuse_log.cgi split-logfile
+ CLEAN_TARGETS = suexec
+-bin_PROGRAMS = htpasswd htdigest htdbm ab logresolve httxt2dbm
++bin_PROGRAMS = htpasswd htdigest htdbm ab logresolve httxt2dbm dbmmanage
+ sbin_PROGRAMS = htcacheclean rotatelogs $(NONPORTABLE_SUPPORT)
+ TARGETS  = $(bin_PROGRAMS) $(sbin_PROGRAMS)
+@@ -15,26 +15,18 @@
+ install:
+       @test -d $(DESTDIR)$(bindir) || $(MKINSTALLDIRS) $(DESTDIR)$(bindir)
+       @test -d $(DESTDIR)$(sbindir) || $(MKINSTALLDIRS) $(DESTDIR)$(sbindir)
+-      @test -d $(DESTDIR)$(libexecdir) || $(MKINSTALLDIRS) $(DESTDIR)$(libexecdir)
+-      @cp -p $(top_builddir)/server/httpd.exp $(DESTDIR)$(libexecdir)
+-      @for i in apxs dbmmanage; do \
++      @for i in $(bin_PROGRAMS); do \
+           if test -f "$(builddir)/$$i"; then \
+               cp -p $$i $(DESTDIR)$(bindir); \
+               chmod 755 $(DESTDIR)$(bindir)/$$i; \
+           fi ; \
+       done
+-      @for i in apachectl; do \
++      @for i in $(sbin_PROGRAMS); do \
+           if test -f "$(builddir)/$$i"; then \
+               cp -p $$i $(DESTDIR)$(sbindir); \
+               chmod 755 $(DESTDIR)$(sbindir)/$$i; \
+           fi ; \
+       done
+-      @if test -f "$(builddir)/envvars-std"; then \
+-          cp -p envvars-std $(DESTDIR)$(sbindir); \
+-          if test ! -f $(DESTDIR)$(sbindir)/envvars; then \
+-              cp -p envvars-std $(DESTDIR)$(sbindir)/envvars ; \
+-          fi ; \
+-      fi
+ htpasswd.lo: passwd_common.h
+ passwd_common.lo: passwd_common.h
diff --git a/app-admin/apache-tools/metadata.xml b/app-admin/apache-tools/metadata.xml
new file mode 100644 (file)
index 0000000..f041a58
--- /dev/null
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>polynomial-c@gentoo.org</email>
+               <name>Lars Wendler</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>apache-bugs@gentoo.org</email>
+               <name>Apache project</name>
+       </maintainer>
+       <longdescription lang="en">
+               app-admin/apache-tools contains tools that might be useful without
+               having apache itself installed (like htdigest/htpasswd, but also ab -
+               the apache benchmark).
+       </longdescription>
+</pkgmetadata>