add deprecated sys-boot/grub:0
[portage-squeep] / sys-boot / grub / files / grub-0.97-ncurses-pkgconfig.patch
diff --git a/sys-boot/grub/files/grub-0.97-ncurses-pkgconfig.patch b/sys-boot/grub/files/grub-0.97-ncurses-pkgconfig.patch
new file mode 100644 (file)
index 0000000..d62e434
--- /dev/null
@@ -0,0 +1,18 @@
+--- a/configure.ac     2015-12-17 11:09:56.807893315 -0500
++++ b/configure.ac     2015-12-17 11:11:06.697570856 -0500
+@@ -234,10 +234,14 @@
+ # Unless the user specify --without-curses, check for curses.
+ if test "x$with_curses" != "xno"; then
++  PKG_CHECK_MODULES([NCURSES],[ncurses],[
++    AC_DEFINE(HAVE_LIBCURSES, 1, [Define if you have a curses library])
++    GRUB_LIBS="$GRUB_LIBS $NCURSES_LIBS"
++  ],[
+   AC_CHECK_LIB(ncurses, wgetch, [GRUB_LIBS="$GRUB_LIBS -lncurses"
+   AC_DEFINE(HAVE_LIBCURSES, 1, [Define if you have a curses library])],
+     [AC_CHECK_LIB(curses, wgetch, [GRUB_LIBS="$GRUB_LIBS -lcurses"
+-       AC_DEFINE(HAVE_LIBCURSES, 1, [Define if you have a curses library])])])
++       AC_DEFINE(HAVE_LIBCURSES, 1, [Define if you have a curses library])])])])
+ fi
+ AC_SUBST(GRUB_LIBS)