dogecoind-1.7.0-r1 installs
[portage-squeep] / net-p2p / dogecoind / dogecoind-1.7.0-r1.ebuild
old mode 100755 (executable)
new mode 100644 (file)
index 7453273..d17957b
@@ -4,7 +4,7 @@ EAPI="5"
 
 DB_VER="5.1"
 
-inherit autotools bash-completion-r1 db-use eutils versionator systemd user
+inherit autotools db-use eutils versionator systemd user
 
 MyPV="${PV/_/}"
 MyPN="dogecoin"
@@ -17,7 +17,7 @@ SRC_URI="https://github.com/${MyPN}/${MyPN}/archive/v${MyPV}.tar.gz -> ${MyPN}-v
 LICENSE="MIT ISC GPL-2"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
-IUSE="bash-completion debug examples ipv6 logrotate upnp +wallet test"
+IUSE="debug examples ipv6 logrotate upnp +wallet test"
 
 RDEPEND="
        >=dev-libs/boost-1.41.0[threads(+)]
@@ -82,7 +82,7 @@ src_install() {
 
        newconfd "${FILESDIR}/dogecoin.confd" "${PN}"
        newinitd "${FILESDIR}/dogecoin.initd" "${PN}"
-       systemd_dounit "${FILESDIR}/dogecoind.service"
+#      systemd_dounit "${FILESDIR}/dogecoind.service"
 
        keepdir /var/lib/dogecoin/.dogecoin
        fperms 700 /var/lib/dogecoin
@@ -91,11 +91,11 @@ src_install() {
        dosym /etc/dogecoin/dogecoin.conf /var/lib/dogecoin/.dogecoin/dogecoin.conf
 
        dodoc doc/README.md doc/release-notes.md
-       doman contrib/debian/manpages/{dogecoind.1,dogecoin.conf.5}
+#      doman contrib/debian/manpages/{dogecoind.1,dogecoin.conf.5}
 
-       if use bash-completion; then
-               newbashcomp "contrib/${PN}.bash-completion" "${PN}"
-       fi
+#      if use bash-completion; then
+#              newbashcomp "contrib/${PN}.bash-completion" "${PN}"
+#      fi
 
        if use examples; then
                docinto examples