dogecoind-1.8.0
[portage-squeep] / net-p2p / dogecoind / dogecoind-1.7.0-r1.ebuild
index 911ea5f83bc13824661b03ad2e9a39df37a5f895..4d24c5b508a7d98add42c10f1c8a337e254be05d 100644 (file)
@@ -4,7 +4,7 @@ EAPI="5"
 
 DB_VER="5.1"
 
-inherit autotools bash-completion-r1 db-use eutils versionator systemd user
+inherit autotools db-use eutils versionator systemd user
 
 MyPV="${PV/_/}"
 MyPN="dogecoin"
@@ -17,7 +17,7 @@ SRC_URI="https://github.com/${MyPN}/${MyPN}/archive/v${MyPV}.tar.gz -> ${MyPN}-v
 LICENSE="MIT ISC GPL-2"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
-IUSE="bash-completion debug examples ipv6 logrotate upnp +wallet"
+IUSE="debug examples ipv6 logrotate upnp +wallet test"
 
 RDEPEND="
        >=dev-libs/boost-1.41.0[threads(+)]
@@ -74,6 +74,7 @@ src_test() {
 
 src_install() {
        dobin "src/${PN}"
+       dobin "src/dogecoin-cli"
 
        insinto /etc/dogecoin
        newins "${FILESDIR}/dogecoin.conf" dogecoin.conf
@@ -81,8 +82,8 @@ src_install() {
        fperms 600 /etc/dogecoin/dogecoin.conf
 
        newconfd "${FILESDIR}/dogecoin.confd" "${PN}"
-       newinitd "${FILESDIR}/dogecoin.initd-r1" "${PN}"
-       systemd_dounit "${FILESDIR}/dogecoind.service"
+       newinitd "${FILESDIR}/dogecoin.initd" "${PN}"
+#      systemd_dounit "${FILESDIR}/dogecoind.service"
 
        keepdir /var/lib/dogecoin/.dogecoin
        fperms 700 /var/lib/dogecoin
@@ -91,11 +92,11 @@ src_install() {
        dosym /etc/dogecoin/dogecoin.conf /var/lib/dogecoin/.dogecoin/dogecoin.conf
 
        dodoc doc/README.md doc/release-notes.md
-       doman contrib/debian/manpages/{dogecoind.1,dogecoin.conf.5}
+#      doman contrib/debian/manpages/{dogecoind.1,dogecoin.conf.5}
 
-       if use bash-completion; then
-               newbashcomp "contrib/${PN}.bash-completion" "${PN}"
-       fi
+#      if use bash-completion; then
+#              newbashcomp "contrib/${PN}.bash-completion" "${PN}"
+#      fi
 
        if use examples; then
                docinto examples