half-assed update of dogecoind so it stops breaking portage
[portage-squeep] / net-p2p / dogecoind / dogecoind-1.14.5-r2.ebuild
similarity index 90%
rename from net-p2p/dogecoind/dogecoind-1.14.5-r1.ebuild
rename to net-p2p/dogecoind/dogecoind-1.14.5-r2.ebuild
index 9d18405df44c55e79e908653a16d1f6913277f63..84819497355c753d5a8829020b59264177f66e19 100644 (file)
@@ -1,12 +1,11 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
-# $Id$
 
-EAPI="5"
+EAPI=7
 
 DB_VER="5.1"
 
-inherit autotools db-use eutils flag-o-matic versionator systemd user
+inherit autotools db-use flag-o-matic systemd
 
 MyPV="${PV/_/}"
 MyPN="dogecoin"
@@ -41,16 +40,17 @@ DEPEND="${RDEPEND}
 
 S="${WORKDIR}/${MyP}"
 
-pkg_setup() {
-       local UG='dogecoin'
-       enewgroup "${UG}"
-       enewuser "${UG}" -1 -1 /var/lib/dogecoin "${UG}"
-}
+pkg_setup() {
+#      local UG='dogecoin'
+#      enewgroup "${UG}"
+#      enewuser "${UG}" -1 -1 /var/lib/dogecoin "${UG}"
+}
 
 src_prepare() {
 #      epatch "${FILESDIR}/0001-Fix-for-Boost-1.74.patch"
 #      epatch "${FILESDIR}/0002-httpserver-include-deque.patch"
 #      epatch_user
+       default
        eautoreconf
 }