update net-mail/vacation
[portage-squeep] / net-mail / vacation / vacation-1.2.7.1-r1.ebuild
similarity index 72%
rename from net-mail/vacation/vacation-1.2.7.0.ebuild
rename to net-mail/vacation/vacation-1.2.7.1-r1.ebuild
index a564b6285344122bfd969d15397f6086dfe1116b..3602bcd0ea9a6f00b3248f1b270828eb660e1769 100644 (file)
@@ -1,9 +1,9 @@
 # Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=0
+EAPI=8
 
-inherit eutils toolchain-funcs
+#inherit eutils toolchain-funcs
 
 DESCRIPTION="automatic mail answering program"
 HOMEPAGE="http://vacation.sourceforge.net/"
@@ -27,12 +27,14 @@ src_unpack() {
 }
 
 src_compile () {
-       emake CC=$(tc-getCC) ARCH=$(tc-arch-kernel) CFLAGS="${CFLAGS} -DMAIN" || die "emake failed."
+       CFLAGS="${CFLAGS} -DMAIN"
+       emake
+       #emake CC=$(tc-getCC) ARCH=$(tc-arch-kernel) CFLAGS="${CFLAGS} -DMAIN" || die "emake failed."
 }
 
 src_install () {
        dodir /usr/bin
        dodir /usr/share/man/man1
-       emake BINDIR="${D}/usr/bin" MANDIR="${D}usr/share/man/man" install || die \
+       emake BINDIR="${D}/usr/bin" MANDIR="${D}/usr/share/man/man" install || die \
        "make install failed"
 }