games-server/fbmuck
[portage-squeep] / games-server / fbmuck / files / fbmuck-6.07-gentoo.patch
diff --git a/games-server/fbmuck/files/fbmuck-6.07-gentoo.patch b/games-server/fbmuck/files/fbmuck-6.07-gentoo.patch
new file mode 100644 (file)
index 0000000..d41555f
--- /dev/null
@@ -0,0 +1,55 @@
+diff -Bru fbmuck-6.07.orig/src/Makefile.in fbmuck-6.07/src/Makefile.in
+--- fbmuck-6.07.orig/src/Makefile.in   2005-08-28 17:32:59.000000000 -0700
++++ fbmuck-6.07/src/Makefile.in        2006-11-21 11:45:00.000000000 -0800
+@@ -37,15 +37,15 @@
+ INCLUDE= ${ROOT}/include
+ # The root of the directory tree to install to.
+-prefix=@prefix@
++prefix=${D}@prefix@
+ exec_prefix=@exec_prefix@
+ # Destinations for binaries
+ INSTALL_BINDIR=@bindir@
+ INSTALL_SBINDIR=@sbindir@
+ # Destination for helpfiles
+-INSTALL_HELPDIR=@datadir@/fbmuck
++INSTALL_HELPDIR=${D}@datadir@/fbmuck
+ # Destination for starter databases
+-INSTALL_DBSDIR=@datadir@/fbmuck/starter_dbs
++INSTALL_DBSDIR=${D}@datadir@/fbmuck/starter_dbs
+ # ${DESTDIR} is used by the Debian packaging system to build the .debs
+ # and is defined by the debian/rules file.
+@@ -168,7 +168,7 @@
+       @echo "#define BINDIR \"$(INSTALL_BINDIR)\"" >> $(INCLUDE)/defines.h
+       @echo "#define INSTALL_HELPDIR \"$(INSTALL_HELPDIR)\"" >> $(INCLUDE)/defines.h
+-fbmuck: $(INCLUDE)/defines.h libpcre.a ${P} ${COBJ} ${MALLOBJ} interface.o ${LOBJ} mkversion.sh Makefile
++fbmuck: $(INCLUDE)/defines.h libpcre.a ${COBJ} ${MALLOBJ} interface.o ${LOBJ} mkversion.sh Makefile
+       sh mkversion.sh
+       ${PRE} ${CC} ${CFLAGS} ${INCL} ${DEFS} -c version.c
+       if [ -f fbmuck ]; then ${MV} fbmuck fbmuck~ ; fi
+diff -Bru fbmuck-6.07.orig/src/mkversion.sh fbmuck-6.07/src/mkversion.sh
+--- fbmuck-6.07.orig/src/mkversion.sh  2005-07-06 21:32:32.000000000 -0700
++++ fbmuck-6.07/src/mkversion.sh       2006-11-21 11:44:08.000000000 -0800
+@@ -241,7 +241,6 @@
+       notify_nolisten(player, smatch_h_version, 1);
+       notify_nolisten(player, speech_h_version, 1);
+       notify_nolisten(player, tune_h_version, 1);
+-      notify_nolisten(player, version_h_version, 1);
+       return;
+ }
+diff -Bru fbmuck-6.07.orig/src/predicates.c fbmuck-6.07/src/predicates.c
+--- fbmuck-6.07.orig/src/predicates.c   2006-11-26 18:04:52.000000000 -0800
++++ fbmuck-6.07/src/predicates.c        2006-11-26 17:57:28.000000000 -0800
+@@ -549,7 +549,7 @@
+ #else                                                 /* !GOD_PRIV */
+                       /* We don't want someone setting themselves !W, to prevent
+                        * a case where there are no wizards at all */
+-                      return ((Typeof(thing) == TYPE_PLAYER && thing == OWNER(player));
++                      return ((Typeof(thing) == TYPE_PLAYER) && thing == OWNER(player));
+ #endif                                                        /* GOD_PRIV */
+               } else
+                       return 1;
+