games-server/fbmuck
[portage-squeep] / games-server / fbmuck / files / fbmuck-6.05-gentoo.patch
diff --git a/games-server/fbmuck/files/fbmuck-6.05-gentoo.patch b/games-server/fbmuck/files/fbmuck-6.05-gentoo.patch
new file mode 100644 (file)
index 0000000..f469b8a
--- /dev/null
@@ -0,0 +1,31 @@
+diff -Bru fbmuck-6.05.orig/src/Makefile.in fbmuck-6.05/src/Makefile.in
+--- fbmuck-6.05.orig/src/Makefile.in   2003-06-22 17:06:45.000000000 -0700
++++ fbmuck-6.05/src/Makefile.in        2004-02-03 14:59:24.291796462 -0800
+@@ -37,15 +37,15 @@
+ INCLUDE= ${ROOT}/include
+ # The root of the directory tree to install to.
+-prefix=@prefix@
++prefix=${D}@prefix@
+ exec_prefix=@exec_prefix@
+ # Destinations for binaries
+ INSTALL_BINDIR=@bindir@
+ INSTALL_SBINDIR=@sbindir@
+ # Destination for helpfiles
+-INSTALL_HELPDIR=@datadir@/fbmuck
++INSTALL_HELPDIR=${D}@datadir@/fbmuck
+ # Destination for starter databases
+-INSTALL_DBSDIR=@datadir@/fbmuck/starter_dbs
++INSTALL_DBSDIR=${D}@datadir@/fbmuck/starter_dbs
+ # ${DESTDIR} is used by the Debian packaging system to build the .debs
+ # and is defined by the debian/rules file.
+@@ -162,7 +162,7 @@
+ all: ${TARGETS} 
+-fbmuck: libpcre.a ${P} ${COBJ} ${MALLOBJ} interface.o ${LOBJ} mkversion.sh Makefile
++fbmuck: libpcre.a ${COBJ} ${MALLOBJ} interface.o ${LOBJ} mkversion.sh Makefile
+       sh mkversion.sh
+       ${PRE} ${CC} ${CFLAGS} ${INCL} ${DEFS} -c version.c
+       if [ -e fbmuck ]; then ${MV} fbmuck fbmuck~ ; fi