games-server/fbmuck
[portage-squeep] / games-server / fbmuck / fbmuck-6.12.ebuild
diff --git a/games-server/fbmuck/fbmuck-6.12.ebuild b/games-server/fbmuck/fbmuck-6.12.ebuild
new file mode 100644 (file)
index 0000000..acba239
--- /dev/null
@@ -0,0 +1,57 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+
+inherit eutils fixheadtails
+
+IUSE="ssl ipv6 diskbase debug pcre"
+
+DESCRIPTION="A database-backed multi-user chat server."
+SRC_URI="mirror://sourceforge/fbmuck/${P}.tar.gz"
+HOMEPAGE="http://www.belfry.com/fuzzball/"
+
+SLOT="2"
+LICENSE="GPL-2"
+KEYWORDS="x86 amd64"
+
+DEPEND=">=sys-apps/sed-4
+               ssl? ( dev-libs/openssl )"
+
+RDEPEND="ssl? ( dev-libs/openssl )
+                pcre? ( dev-libs/libpcre )"
+
+RESTRICT="nostrip"
+
+src_unpack() {
+       unpack ${A}
+       ht_fix_all
+#      epatch ${FILESDIR}/${P}-gentoo.patch
+}
+
+src_compile() {
+       use diskbase && sed -i -e 's:#undef DISKBASE:#define DISKBASE:' include/config.h
+       econf \
+               `use_with ssl ssl=/usr` \
+               `use_with pcre pcre=/usr` \
+               `use_enable ipv6` \
+               `use_enable debug` \
+               || die "Could not configure"
+       emake || die "Could not make"
+}
+
+src_install() {
+       dodir /usr/bin
+       keepdir /usr/share/fbmuck
+
+       make DESTDIR=${D} install || die "Could not install"
+
+       exeinto /usr/bin
+       doexe ${FILESDIR}/fbmuckctl
+
+       exeinto /etc/init.d
+       doexe ${FILESDIR}/fbmuck
+
+       insinto /etc
+       doins ${FILESDIR}/fbmucks
+
+       dodoc CHANGESfb6 INSTALLATION README
+}