new dev-util/cdecl
[portage-squeep] / dev-util / cdecl / cdecl-10.2.ebuild
diff --git a/dev-util/cdecl/cdecl-10.2.ebuild b/dev-util/cdecl/cdecl-10.2.ebuild
new file mode 100644 (file)
index 0000000..247a7dd
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+#inherit eutils toolchain-funcs
+
+DESCRIPTION="Compose and decipher C (or C++) declarations or casts, aka 'gibberish.'"
+SRC_URI="https://github.com/paul-j-lucas/cdecl/releases/download/${P}/${P}.tar.gz"
+HOMEPAGE="https://github.com/paul-j-lucas/cdecl"
+
+KEYWORDS="amd64 x86"
+LICENSE="public-domain"
+SLOT="0"
+
+RDEPEND="readline? (
+                       sys-libs/ncurses
+                       sys-libs/readline
+                       )"
+
+DEPEND="${RDEPEND}
+               || (
+                       dev-util/yacc
+                       sys-devel/bison
+                       )
+               !<dev-util/cutils-1.6-r2"
+
+IUSE="readline"
+
+src_install() {
+       emake DESTDIR="${D}" install
+}