7b4117a3ec2fe003f7e844af9ab6a921dd0d7edd
[portage-squeep] / www-servers / apache / apache-2.4.18-r1.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 # latest gentoo apache files
8 GENTOO_PATCHSTAMP="20160303"
9 GENTOO_DEVELOPER="polynomial-c"
10 GENTOO_PATCHNAME="gentoo-apache-2.4.18-r1"
11
12 # IUSE/USE_EXPAND magic
13 IUSE_MPMS_FORK="prefork"
14 IUSE_MPMS_THREAD="event worker"
15
16 # << obsolete modules:
17 # authn_default authz_default mem_cache
18 # mem_cache is replaced by cache_disk
19 # ?? buggy modules
20 # proxy_scgi: startup error: undefined symbol "ap_proxy_release_connection", no fix found
21 # >> added modules for reason:
22 # compat: compatibility with 2.2 access control
23 # authz_host: new module for access control
24 # authn_core: functionality provided by authn_alias in previous versions
25 # authz_core: new module, provides core authorization capabilities
26 # cache_disk: replacement for mem_cache
27 # lbmethod_byrequests: Split off from mod_proxy_balancer in 2.3
28 # lbmethod_bytraffic: Split off from mod_proxy_balancer in 2.3
29 # lbmethod_bybusyness: Split off from mod_proxy_balancer in 2.3
30 # lbmethod_heartbeat: Split off from mod_proxy_balancer in 2.3
31 # slotmem_shm: Slot-based shared memory provider (for lbmethod_byrequests).
32 # socache_shmcb: shared object cache provider. Default config with ssl needs it
33 # unixd: fixes startup error: Invalid command 'User'
34 IUSE_MODULES="access_compat actions alias asis auth_basic auth_digest
35 authn_alias authn_anon authn_core authn_dbd authn_dbm authn_file authz_core
36 authz_dbd authz_dbm authz_groupfile authz_host authz_owner authz_user autoindex
37 cache cache_disk cern_meta charset_lite cgi cgid dav dav_fs dav_lock dbd deflate
38 dir dumpio env expires ext_filter file_cache filter headers http2 ident imagemap
39 include info lbmethod_byrequests lbmethod_bytraffic lbmethod_bybusyness
40 lbmethod_heartbeat log_config log_forensic logio macro mime mime_magic negotiation
41 proxy proxy_ajp proxy_balancer proxy_connect proxy_ftp proxy_html proxy_http proxy_scgi
42 proxy_fcgi proxy_wstunnel rewrite ratelimit remoteip reqtimeout setenvif
43 slotmem_shm speling socache_shmcb status substitute unique_id userdir usertrack
44 unixd version vhost_alias"
45 # The following are also in the source as of this version, but are not available
46 # for user selection:
47 # bucketeer case_filter case_filter_in echo http isapi optional_fn_export
48 # optional_fn_import optional_hook_export optional_hook_import
49
50 # inter-module dependencies
51 # TODO: this may still be incomplete
52 MODULE_DEPENDS="
53 dav_fs:dav
54 dav_lock:dav
55 deflate:filter
56 cache_disk:cache
57 ext_filter:filter
58 file_cache:cache
59 lbmethod_byrequests:proxy_balancer
60 lbmethod_byrequests:slotmem_shm
61 lbmethod_bytraffic:proxy_balancer
62 lbmethod_bybusyness:proxy_balancer
63 lbmethod_heartbeat:proxy_balancer
64 log_forensic:log_config
65 logio:log_config
66 cache_disk:cache
67 mime_magic:mime
68 proxy_ajp:proxy
69 proxy_balancer:proxy
70 proxy_balancer:slotmem_shm
71 proxy_connect:proxy
72 proxy_ftp:proxy
73 proxy_html:proxy
74 proxy_http:proxy
75 proxy_scgi:proxy
76 proxy_fcgi:proxy
77 proxy_wstunnel:proxy
78 substitute:filter
79 "
80
81 # module<->define mappings
82 MODULE_DEFINES="
83 auth_digest:AUTH_DIGEST
84 authnz_ldap:AUTHNZ_LDAP
85 cache:CACHE
86 cache_disk:CACHE
87 dav:DAV
88 dav_fs:DAV
89 dav_lock:DAV
90 file_cache:CACHE
91 http2:HTTP2
92 info:INFO
93 ldap:LDAP
94 proxy:PROXY
95 proxy_ajp:PROXY
96 proxy_balancer:PROXY
97 proxy_connect:PROXY
98 proxy_ftp:PROXY
99 proxy_html:PROXY
100 proxy_http:PROXY
101 proxy_fcgi:PROXY
102 proxy_scgi:PROXY
103 proxy_wstunnel:PROXY
104 socache_shmcb:SSL
105 ssl:SSL
106 status:STATUS
107 suexec:SUEXEC
108 userdir:USERDIR
109 "
110
111 # critical modules for the default config
112 MODULE_CRITICAL="
113 authn_core
114 authz_core
115 authz_host
116 dir
117 mime
118 unixd
119 "
120 inherit eutils apache-2 systemd toolchain-funcs
121
122 DESCRIPTION="The Apache Web Server"
123 HOMEPAGE="http://httpd.apache.org/"
124
125 # some helper scripts are Apache-1.1, thus both are here
126 LICENSE="Apache-2.0 Apache-1.1"
127 SLOT="2"
128 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x64-macos ~x86-macos ~m68k-mint ~sparc64-solaris ~x64-solaris"
129
130 DEPEND+="apache2_modules_http2? ( >=net-libs/nghttp2-1.2.1 )"
131
132 REQUIRED_USE="apache2_modules_http2? ( ssl )"
133
134 pkg_setup() {
135 # dependend critical modules which are not allowed in global scope due
136 # to USE flag conditionals (bug #499260)
137 use ssl && MODULE_CRITICAL+=" socache_shmcb"
138 use doc && MODULE_CRITICAL+=" alias negotiation setenvif"
139 apache-2_pkg_setup
140 }
141
142 src_configure() {
143 # Brain dead check.
144 tc-is-cross-compiler && export ap_cv_void_ptr_lt_long="no"
145
146 apache-2_src_configure
147 }
148
149 src_compile() {
150 if tc-is-cross-compiler; then
151 # This header is the same across targets, so use the build compiler.
152 pushd server >/dev/null
153 emake gen_test_char
154 tc-export_build_env BUILD_CC
155 ${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_CPPFLAGS} ${BUILD_LDFLAGS} \
156 gen_test_char.c -o gen_test_char $(apr-1-config --includes) || die
157 popd >/dev/null
158 fi
159
160 default
161 }
162
163 src_install() {
164 apache-2_src_install
165 for i in /usr/bin/{htdigest,logresolve,htpasswd,htdbm,ab,httxt2dbm}; do
166 rm "${ED}"/$i || die "Failed to prune apache-tools bits"
167 done
168 for i in /usr/share/man/man8/{rotatelogs.8,htcacheclean.8}; do
169 rm "${ED}"/$i || die "Failed to prune apache-tools bits"
170 done
171 for i in /usr/share/man/man1/{logresolve.1,htdbm.1,htdigest.1,htpasswd.1,dbmmanage.1,ab.1}; do
172 rm "${ED}"/$i || die "Failed to prune apache-tools bits"
173 done
174 for i in /usr/sbin/{checkgid,fcgistarter,htcacheclean,rotatelogs}; do
175 rm "${ED}/"$i || die "Failed to prune apache-tools bits"
176 done
177
178 # install apxs in /usr/bin (bug #502384) and put a symlink into the
179 # old location until all ebuilds and eclasses have been modified to
180 # use the new location.
181 local apxs="/usr/bin/apxs"
182 cp "${S}"/support/apxs "${ED}"${apxs} || die "Failed to install apxs"
183 ln -s ../bin/apxs "${ED}"/usr/sbin/apxs || die
184 chmod 0755 "${ED}"${apxs} || die
185
186 # Note: wait for mod_systemd to be included in the next release,
187 # then apache2.4.service can be used and systemd support controlled
188 # through --enable-systemd
189 systemd_newunit "${FILESDIR}/apache2.2.service" "apache2.service"
190 systemd_dotmpfilesd "${FILESDIR}/apache.conf"
191 #insinto /etc/apache2/modules.d
192 #doins "${FILESDIR}/00_systemd.conf"
193
194 # Install http2 module config
195 insinto /etc/apache2/modules.d
196 doins "${FILESDIR}"/41_mod_http2.conf
197 }
198
199 pkg_postinst()
200 {
201 apache-2_pkg_postinst || die "apache-2_pkg_postinst failed"
202 # warnings that default config might not work out of the box
203 for mod in $MODULE_CRITICAL; do
204 if ! use "apache2_modules_${mod}"; then
205 echo
206 ewarn "Warning: Critical module not installed!"
207 ewarn "Modules 'authn_core', 'authz_core' and 'unixd'"
208 ewarn "are highly recomended but might not be in the base profile yet."
209 ewarn "Default config for ssl needs module 'socache_shmcb'."
210 ewarn "Enabling the following flags is highly recommended:"
211 for cmod in $MODULE_CRITICAL; do
212 use "apache2_modules_${cmod}" || \
213 ewarn "+ apache2_modules_${cmod}"
214 done
215 echo
216 break
217 fi
218 done
219 # warning for proxy_balancer and missing load balancing scheduler
220 if use apache2_modules_proxy_balancer; then
221 local lbset=
222 for mod in lbmethod_byrequests lbmethod_bytraffic lbmethod_bybusyness lbmethod_heartbeat; do
223 if use "apache2_modules_${mod}"; then
224 lbset=1 && break
225 fi
226 done
227 if [ ! $lbset ]; then
228 echo
229 ewarn "Info: Missing load balancing scheduler algorithm module"
230 ewarn "(They were split off from proxy_balancer in 2.3)"
231 ewarn "In order to get the ability of load balancing, at least"
232 ewarn "one of these modules has to be present:"
233 ewarn "lbmethod_byrequests lbmethod_bytraffic lbmethod_bybusyness lbmethod_heartbeat"
234 echo
235 fi
236 fi
237 }
238