acba2395725c1de2087be7721940144fcbb36ab7
[portage-squeep] / games-server / fbmuck / fbmuck-6.12.ebuild
1 # Copyright 1999-2004 Gentoo Technologies, Inc.
2 # Distributed under the terms of the GNU General Public License v2
3
4 inherit eutils fixheadtails
5
6 IUSE="ssl ipv6 diskbase debug pcre"
7
8 DESCRIPTION="A database-backed multi-user chat server."
9 SRC_URI="mirror://sourceforge/fbmuck/${P}.tar.gz"
10 HOMEPAGE="http://www.belfry.com/fuzzball/"
11
12 SLOT="2"
13 LICENSE="GPL-2"
14 KEYWORDS="x86 amd64"
15
16 DEPEND=">=sys-apps/sed-4
17 ssl? ( dev-libs/openssl )"
18
19 RDEPEND="ssl? ( dev-libs/openssl )
20 pcre? ( dev-libs/libpcre )"
21
22 RESTRICT="nostrip"
23
24 src_unpack() {
25 unpack ${A}
26 ht_fix_all
27 # epatch ${FILESDIR}/${P}-gentoo.patch
28 }
29
30 src_compile() {
31 use diskbase && sed -i -e 's:#undef DISKBASE:#define DISKBASE:' include/config.h
32 econf \
33 `use_with ssl ssl=/usr` \
34 `use_with pcre pcre=/usr` \
35 `use_enable ipv6` \
36 `use_enable debug` \
37 || die "Could not configure"
38 emake || die "Could not make"
39 }
40
41 src_install() {
42 dodir /usr/bin
43 keepdir /usr/share/fbmuck
44
45 make DESTDIR=${D} install || die "Could not install"
46
47 exeinto /usr/bin
48 doexe ${FILESDIR}/fbmuckctl
49
50 exeinto /etc/init.d
51 doexe ${FILESDIR}/fbmuck
52
53 insinto /etc
54 doins ${FILESDIR}/fbmucks
55
56 dodoc CHANGESfb6 INSTALLATION README
57 }