disable old apache-tools, old eapi
[portage-squeep] / app-admin / .unused / apache-tools / files / apache-tools-2.2.20-Makefile.patch
diff --git a/app-admin/.unused/apache-tools/files/apache-tools-2.2.20-Makefile.patch b/app-admin/.unused/apache-tools/files/apache-tools-2.2.20-Makefile.patch
new file mode 100644 (file)
index 0000000..7bc3952
--- /dev/null
@@ -0,0 +1,41 @@
+=== modified file 'support/Makefile.in'
+--- a/support/Makefile.in
++++ b/support/Makefile.in
+@@ -1,9 +1,10 @@
+ DISTCLEAN_TARGETS = apxs apachectl dbmmanage log_server_status \
+-      logresolve.pl phf_abuse_log.cgi split-logfile envvars-std
++      logresolve.pl phf_abuse_log.cgi split-logfile
+ CLEAN_TARGETS = suexec
+-PROGRAMS = htpasswd htdigest rotatelogs logresolve ab htdbm htcacheclean httxt2dbm $(NONPORTABLE_SUPPORT)
++PROGRAMS = htpasswd htdigest rotatelogs logresolve ab htdbm htcacheclean httxt2dbm \
++      $(NONPORTABLE_SUPPORT) log_server_status split-logfile dbmmanage
+ TARGETS  = $(PROGRAMS)
+ PROGRAM_LDADD        = $(UTIL_LDFLAGS) $(PROGRAM_DEPENDENCIES) $(EXTRA_LIBS) $(AP_LIBS)
+@@ -12,22 +13,13 @@
+ include $(top_builddir)/build/rules.mk
+ install:
+-      @test -d $(DESTDIR)$(bindir) || $(MKINSTALLDIRS) $(DESTDIR)$(bindir)
+       @test -d $(DESTDIR)$(sbindir) || $(MKINSTALLDIRS) $(DESTDIR)$(sbindir)
+-      @test -d $(DESTDIR)$(libexecdir) || $(MKINSTALLDIRS) $(DESTDIR)$(libexecdir)
+-      @cp -p $(top_builddir)/server/httpd.exp $(DESTDIR)$(libexecdir)
+-      @for i in apxs apachectl dbmmanage; do \
++      @for i in $(PROGRAMS) ; do \
+           if test -f "$(builddir)/$$i"; then \
+               cp -p $$i $(DESTDIR)$(sbindir); \
+               chmod 755 $(DESTDIR)$(sbindir)/$$i; \
+           fi ; \
+       done
+-      @if test -f "$(builddir)/envvars-std"; then \
+-          cp -p envvars-std $(DESTDIR)$(sbindir); \
+-          if test ! -f $(DESTDIR)$(sbindir)/envvars; then \
+-              cp -p envvars-std $(DESTDIR)$(sbindir)/envvars ; \
+-          fi ; \
+-      fi
+ htpasswd_OBJECTS = htpasswd.lo
+ htpasswd: $(htpasswd_OBJECTS)
+