dogecoind-1.7.0-r1 installs correct file in init.d
[portage-squeep] / net-p2p / dogecoind / dogecoind-1.7.0-r1.ebuild
old mode 100644 (file)
new mode 100755 (executable)
index 911ea5f..7453273
@@ -17,7 +17,7 @@ SRC_URI="https://github.com/${MyPN}/${MyPN}/archive/v${MyPV}.tar.gz -> ${MyPN}-v
 LICENSE="MIT ISC GPL-2"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
-IUSE="bash-completion debug examples ipv6 logrotate upnp +wallet"
+IUSE="bash-completion debug examples ipv6 logrotate upnp +wallet test"
 
 RDEPEND="
        >=dev-libs/boost-1.41.0[threads(+)]
@@ -81,7 +81,7 @@ src_install() {
        fperms 600 /etc/dogecoin/dogecoin.conf
 
        newconfd "${FILESDIR}/dogecoin.confd" "${PN}"
-       newinitd "${FILESDIR}/dogecoin.initd-r1" "${PN}"
+       newinitd "${FILESDIR}/dogecoin.initd" "${PN}"
        systemd_dounit "${FILESDIR}/dogecoind.service"
 
        keepdir /var/lib/dogecoin/.dogecoin