add net-mail/vacation
authorJustin Wind <justin.wind+git@gmail.com>
Sat, 5 Oct 2019 17:04:46 +0000 (10:04 -0700)
committerJustin Wind <justin.wind+git@gmail.com>
Sat, 5 Oct 2019 17:04:46 +0000 (10:04 -0700)
net-mail/vacation/Manifest [new file with mode: 0644]
net-mail/vacation/metadata.xml [new file with mode: 0644]
net-mail/vacation/vacation-1.2.7.0.ebuild [new file with mode: 0644]
net-mail/vacation/vacation-1.2.7.1.ebuild [new file with mode: 0644]

diff --git a/net-mail/vacation/Manifest b/net-mail/vacation/Manifest
new file mode 100644 (file)
index 0000000..9319749
--- /dev/null
@@ -0,0 +1,5 @@
+DIST vacation-1.2.7.0.tar.gz 63849 BLAKE2B d2f2737677b0fe075041bac0a32b6f5f57d072040448b61416e7fee98e7d4184bbd22e25734ed5e4deeabb0d0c32953821d383c9d16cf79b325fa7f261956333 SHA512 50473777fa5d36c1b7ab438e1072a56298f8155c7aaa8f8d8daaa1dee5f85f54a7b17903c416e67dbac734368b1cdbbc599cd9aa58132b0ecb145ae8e058e97d
+DIST vacation-1.2.7.1.tar.gz 36328 BLAKE2B 0a848518a575b939e73c70864d898c5028cc27ba890dc0b66c67700bd5b54b5c2935788229b2a80b6742c12b0e26b854c9cc90a7732ac4d2237ce6cc5fee3dde SHA512 0057c12544316bcf79417aba0bff723ab795835eb4fafba7e78ee002a6e0a5e9824e0dbf5f802293cf6b881a678ed35883444943a5db14b39ea295e7e8f6bd34
+EBUILD vacation-1.2.7.0.ebuild 853 BLAKE2B c6cafd7768e1cd844d9b4c7b97a03914278d6dc200a667a48647866fc87a96b793f01c146f2a776d221d5fad92a97afde61b9c1de6e3b5e3b14af181201b6f7b SHA512 18db109406292bcaecd4f677c5761d3eea36d4398b445850b88a12cb8de987b9f9518c4db0354ff46bf82b819b7aecc9d9bd391bb895b68088f27fed2bf61b7a
+EBUILD vacation-1.2.7.1.ebuild 853 BLAKE2B c6cafd7768e1cd844d9b4c7b97a03914278d6dc200a667a48647866fc87a96b793f01c146f2a776d221d5fad92a97afde61b9c1de6e3b5e3b14af181201b6f7b SHA512 18db109406292bcaecd4f677c5761d3eea36d4398b445850b88a12cb8de987b9f9518c4db0354ff46bf82b819b7aecc9d9bd391bb895b68088f27fed2bf61b7a
+MISC metadata.xml 250 BLAKE2B d0daf7c0246f1ceb0d3323e9c0a24dcd85198cbd2a1cee896efc79add248a7ecd4d84a47d82d4681d44adb831285c82aedab58d1ad4aff0337deaf39c8df5de3 SHA512 eb1ce5a9aee93887dfd2e2492529a60e4b95b9dbf2dd1bb49cfa4cc00cc1388fe8c2d7f0c51a9155df1b0f7f04035aca2e3320ead405517e3da2d34914515c1e
diff --git a/net-mail/vacation/metadata.xml b/net-mail/vacation/metadata.xml
new file mode 100644 (file)
index 0000000..442218c
--- /dev/null
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <!-- maintainer-needed -->
+  <upstream>
+    <remote-id type="sourceforge">vacation</remote-id>
+  </upstream>
+</pkgmetadata>
diff --git a/net-mail/vacation/vacation-1.2.7.0.ebuild b/net-mail/vacation/vacation-1.2.7.0.ebuild
new file mode 100644 (file)
index 0000000..a564b62
--- /dev/null
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=0
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="automatic mail answering program"
+HOMEPAGE="http://vacation.sourceforge.net/"
+SRC_URI="mirror://sourceforge/vacation/${P}.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="alpha amd64 x86"
+SLOT="0"
+IUSE=""
+
+RDEPEND="virtual/mta
+       sys-libs/gdbm"
+DEPEND="${RDEPEND}
+       !mail-mta/sendmail"
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+
+       sed -i -e "s:install -s -m:install -m:" Makefile
+       sed -i -e "s:-Xlinker:${LDFLAGS} -Xlinker:" Makefile
+}
+
+src_compile () {
+       emake CC=$(tc-getCC) ARCH=$(tc-arch-kernel) CFLAGS="${CFLAGS} -DMAIN" || die "emake failed."
+}
+
+src_install () {
+       dodir /usr/bin
+       dodir /usr/share/man/man1
+       emake BINDIR="${D}/usr/bin" MANDIR="${D}usr/share/man/man" install || die \
+       "make install failed"
+}
diff --git a/net-mail/vacation/vacation-1.2.7.1.ebuild b/net-mail/vacation/vacation-1.2.7.1.ebuild
new file mode 100644 (file)
index 0000000..a564b62
--- /dev/null
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=0
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="automatic mail answering program"
+HOMEPAGE="http://vacation.sourceforge.net/"
+SRC_URI="mirror://sourceforge/vacation/${P}.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="alpha amd64 x86"
+SLOT="0"
+IUSE=""
+
+RDEPEND="virtual/mta
+       sys-libs/gdbm"
+DEPEND="${RDEPEND}
+       !mail-mta/sendmail"
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+
+       sed -i -e "s:install -s -m:install -m:" Makefile
+       sed -i -e "s:-Xlinker:${LDFLAGS} -Xlinker:" Makefile
+}
+
+src_compile () {
+       emake CC=$(tc-getCC) ARCH=$(tc-arch-kernel) CFLAGS="${CFLAGS} -DMAIN" || die "emake failed."
+}
+
+src_install () {
+       dodir /usr/bin
+       dodir /usr/share/man/man1
+       emake BINDIR="${D}/usr/bin" MANDIR="${D}usr/share/man/man" install || die \
+       "make install failed"
+}